The integrated cross-platform development tool for ANSI Common Lisp LispWorks logo

System Requirements

Requirements for LispWorks runtimes are the same as for LispWorks itself on the same platform, unless stated otherwise below.


LispWorks 6.1 (32-bit) for Macintosh

  • Requires Mac OS X v. 10.3, 10.4, 10.5, 10.6, 10.7, 10.8 or 10.9.
  • Processor: Intel-based Macintosh, or G3, G4 or G5.
  • 265MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.3 and Imlib, if you want to use the deprecated Motif GUI.

Neither of the alternative GTK+ and Motif GUIs are available in the Personal Edition.


LispWorks 6.1 (64-bit) for Macintosh

  • Requires Mac OS X v. 10.5, 10.6, 10.7, 10.8 or 10.9.
  • Processor: Intel-based Macintosh or G5.
  • 310MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.3 and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.1 (32-bit) for Linux

  • Any Linux distribution with glibc 2.6 or later.
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 155MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can use the command grep sse2 /proc/cpuinfo

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.1 (64-bit) for Linux

  • Any 64-bit Linux distribution with glibc 2.6 or later.
  • Processor: AMD64-compatible, including Intel 64.
  • 175MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.1 (32-bit) for x86/x64 Solaris

  • Solaris 10 (release 5/08 or later), Solaris 11, or OpenSolaris (release 2009.06 or later).
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 130MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Motif 2.1 and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can do grep features: /var/adm/messages* which will find a boot message showing the processor information - look for sse2.

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.1 (64-bit) for x86/x64 Solaris

  • Solaris 10 (release 5/08 or later), Solaris 11, or OpenSolaris (release 2009.06 or later).
  • Processor: AMD64-compatible, including Intel 64.
  • 140MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Motif 2.1 and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.1 (32-bit) for FreeBSD

  • FreeBSD 7.x, or later with compat7x. If you want to run 32-bit LispWorks 6.1 on FreeBSD 6.x, then please contact us.
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 160MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can look at the boot messages in /var/log/messages

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.1 (64-bit) for FreeBSD

  • 64-bit FreeBSD 7.x, or later with compat7x.
  • Processor: AMD64-compatible, including Intel 64.
  • 175MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.1 (32-bit) for Windows

  • Windows 8, Windows 7, Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (all x86 and x64 Editions supported).
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 150MB of disk space for a complete installation with documentation.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can use CPU-Z.

Please see the note below about Windows emulators.


LispWorks 6.1 (64-bit) for Windows

  • Windows 8, Windows 7, Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (x64 Editions only).
  • Processor: AMD64-compatible, including Intel 64.
  • 170MB of disk space for a complete installation with documentation.

LispWorks® 6.1 (64-bit) for SPARC/Solaris

  • 175MB of disk space for a complete installation with documentation.
  • Platforms: 64-bit SPARC running Solaris 2.8 or later.
  • Optional: Motif 2, if you want to use the Motif GUI.

LispWorks® 6.1 (32-bit) for Unix

  • 160MB of disk space for a complete installation with all optional products and documentation.
  • Platforms: SPARC running Solaris 2.8 or later, HP PA running HP-UX 11x.
  • LispWorks also runs on other UNIX workstations. Please ask us if you need a platform which is not mentioned here.
  • Optional: Motif 2, if you want to use the Motif GUI.


System Requirements for older versions

Please note that these products are no longer available to purchase

LispWorks 6.0 (32-bit) for Macintosh

  • Requires Mac OS X v. 10.3.x, 10.4.x, 10.5.x, 10.6.x or 10.7.x.
  • Processor: Intel-based Macintosh, or G3, G4 or G5.
  • 240MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the alternate GTK+ GUI.
  • Optional: Open Motif 2.3 and Imlib, if you want to use the deprecated Motif GUI.

Neither of the alternate GTK+ and Motif GUIs are available in the Personal Edition.


LispWorks 6.0 (64-bit) for Macintosh

  • Requires Mac OS X v. 10.5.x, 10.6.x or 10.7.x.
  • Processor: Intel-based Macintosh or G5.
  • 285MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the alternate GTK+ GUI.
  • Optional: Open Motif 2.3 and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.0 (32-bit) for Linux

  • Any Linux distribution with glibc 2.3.3 or later.
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 155MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can use the command grep sse2 /proc/cpuinfo

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.0 (64-bit) for Linux

  • Any Linux distribution with glibc 2.3.3 or later.
  • Processor: AMD64-compatible, including Intel 64.
  • 175MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.0 (32-bit) for x86/x64 Solaris

  • Solaris 10 (release 5/08 or later) or OpenSolaris (release 2009.06 or later).
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 130MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Motif 2.1 and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can do grep features: /var/adm/messages* which will find a boot message showing the processor information - look for sse2.

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.0 (64-bit) for x86/x64 Solaris

  • Solaris 10 (release 5/08 or later) or OpenSolaris (release 2009.06 or later).
  • Processor: AMD64-compatible, including Intel 64.
  • 140MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Motif 2.1 and Imlib, if you want to use the deprecated Motif GUI.

LispWorks 6.0 (32-bit) for FreeBSD

  • FreeBSD 7.x, or later with compat7x. If you want to run LispWorks 6.0 on FreeBSD 6.x, then please contact us.
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 160MB of disk space for a complete installation with documentation.
  • Optional: GTK+ 2 (version 2.4 or higher), if you want to use the GTK+ GUI.
  • Optional: Open Motif 2.2.x and Imlib, if you want to use the deprecated Motif GUI.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can look at the boot messages in /var/log/messages

The GTK+ GUI is required in the Personal Edition.


LispWorks 6.0 (32-bit) for Windows

  • Windows 7, Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (all x86 and x64 Editions supported).
  • Professional and Enterprise Editions require a Pentium 4-compatible processor with SSE2 technology.
  • Runtimes and the Personal Edition run on any Pentium-compatible processor.
  • 150MB of disk space for a complete installation with documentation.

SSE2 technology dates from 2001 (in the Intel Pentium 4) and 2003 (in AMD processors). Most computers manufactured in recent years have it. To check your processor you can use CPU-Z.

Please see the note below about Windows emulators.


LispWorks 6.0 (64-bit) for Windows

  • Windows 7, Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (x64 Editions only).
  • Processor: AMD64-compatible, including Intel 64.
  • 170MB of disk space for a complete installation with documentation.

LispWorks® 6.0 (64-bit) for SPARC/Solaris

  • 175MB of disk space for a complete installation with documentation.
  • Platforms: 64-bit SPARC running Solaris 2.8 or later.
  • Optional: Motif 2, if you want to use the Motif GUI.

LispWorks® 6.0 (32-bit) for Unix

  • 160MB of disk space for a complete installation with all optional products and documentation.
  • Platforms: SPARC running Solaris 2.8 or later, HP PA running HP-UX 11x.
  • LispWorks also runs on other UNIX workstations. Please ask us if you need a platform which is not mentioned here.
  • Optional: Motif 2, if you want to use the Motif GUI.

LispWorks 5.1 (32-bit) for Macintosh

  • Requires Mac OS X v. 10.3.x, 10.4.x, 10.5.x or 10.6.x.
  • Processor: Intel-based Macintosh, or G3, G4 or G5.
  • 220MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation.
  • 160MB of disk space for a complete installation of the Personal Edition with documentation.
  • OpenMotif 2.3 (only needed if you want to run the alternate X11/Motif GUI in the Professional or Enterprise Edition).

LispWorks 5.1 (64-bit) for Macintosh

  • Requires Mac OS X v. 10.5.x or 10.6.x
  • Processor: Intel-based Macintosh or G5.
  • 260MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • OpenMotif 2.3 (only needed if you want to run the alternate X11/Motif GUI).

LispWorks 5.1 (32-bit) for Linux

  • RedHat Linux (version 9 or later) or a distribution with kernel version 2.4 or later that supports NPTL and glibc 2.3.2 or later.
  • Processor: Pentium-compatible.
  • 155MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation.
  • OpenMotif 2.2 (or higher) for the X11/Motif GUI. The GUI is optional in the Professional and Enterprise Editions. The GUI is required in the Personal Edition.

LispWorks 5.1 (64-bit) for Linux

  • RedHat Linux (version 9 or later) or a distribution with kernel version 2.4 or later that supports NPTL and glibc 2.3.2 or later.
  • Processor: AMD64-compatible, including Intel 64.
  • 175MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • OpenMotif 2.2 (or higher) if you want to run the GUI.

LispWorks 5.1 (32-bit) for FreeBSD

  • FreeBSD 5.4 or later, or FreeBSD 6.0 or later with compat5x.
  • Processor: Pentium-compatible.
  • 160MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation.
  • OpenMotif 2.2 (or higher) for the X11/Motif GUI. The GUI is optional in the Professional and Enterprise Editions, and is required in the Personal Edition.
  • To use the X11/Motif GUI on FreeBSD 7.0, you also need the FreeBSD 5.0 X libraries with LD_LIBRARY_PATH set to find these. Contact us if you need help with this.

LispWorks 5.1 (32-bit) for Windows

  • Windows 7, Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (all x86 and x64 Editions supported), or Windows 2000 SP3, Windows 98 or Windows Millennium Edition.
  • Processor: Pentium-compatible.
  • 150MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation.
  • 130MB of disk space for a complete installation of the Personal Edition with documentation.

Please see the note below about Windows emulators.


LispWorks 5.1 (64-bit) for Windows

  • Windows Vista, Windows Server 2008, Windows XP or Windows Server 2003 (x64 Editions only).
  • Processor: AMD64-compatible, including Intel 64.
  • 170MB of disk space for a complete installation of the Enterprise Edition with documentation.

LispWorks® 5.1 (64-bit) for SPARC/Solaris

  • 175MB of disk space for a complete installation of the Enterprise Edition with documentation.
  • Platforms: 64-bit SPARC running Solaris 2.8 or later.
  • Motif 2, if you want to run the X11/Motif GUI.

LispWorks® 5.1 (32-bit) for Unix

  • 160MB of disk space for a complete installation with all optional products and documentation.
  • Platforms: SPARC running Solaris 2.8 or later, HP PA running HP-UX 11x.
  • LispWorks also runs on other UNIX workstations. Please ask us if you need a platform which is not mentioned here.
  • Motif 2, if you want to run the X11/Motif GUI.


LispWorks 5.0 (32-bit) for Macintosh

  • Requires Mac OS X v. 10.3.x, 10.4.x or later. For LispWorks Professional, Enterprise and Academic Editions on Mac OS X 10.5 (Leopard) some patches are needed.
  • Processor: Intel-based Macintosh, or G3, G4 or G5
  • 200MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation
  • 123MB of disk space for a complete installation of the Personal Edition with documentation
  • OpenMotif 2.3 (only needed if you want to run the alternate X11/Motif GUI in the Professional or Enterprise Edition)

LispWorks 5.0 (64-bit) for Macintosh

  • Requires Mac OS X v. 10.4.5 or later. For Mac OS X 10.5 (Leopard) some patches are needed.
  • Processor: Intel-based Macintosh or G5
  • 180MB of disk space for a complete installation of the Enterprise Edition with documentation
  • OpenMotif 2.3, if you want to run the X11/Motif GUI

LispWorks 5.0 (32-bit) for Linux

  • RedHat Linux (version 9 or later) or a distribution with kernel version 2.4 or later that supports NPTL and glibc 2.3.2 or later
  • Processor: Pentium-compatible
  • 118MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation
  • OpenMotif 2.2 (or higher), for the X11/Motif GUI. The GUI is optional in the Professional and Enterprise Editions. The GUI is required in the Personal Edition.

LispWorks 5.0 (64-bit) for Linux

  • RedHat Linux (version 9 or later) or a distribution with kernel version 2.4 or later that supports NPTL and glibc 2.3.2 or later
  • Processor: AMD64-compatible, including Intel 64
  • 158MB of disk space for a complete installation of the Enterprise Edition with documentation
  • OpenMotif 2.2 (or higher) if you want to run the GUI

LispWorks 5.0 (32-bit) for FreeBSD

  • FreeBSD 5.4 or later, or FreeBSD 6.0 or later with compat5x
  • Processor: Pentium-compatible
  • 111MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation
  • OpenMotif 2.2 (or higher), for the X11/Motif GUI. The GUI is optional in the Professional and Enterprise Editions. The GUI is required in the Personal Edition.

LispWorks 5.0 (32-bit) for Windows

  • Windows Vista, Windows XP, Windows Server 2003, Windows 2000 SP3, Windows 98 or Windows Millennium Edition running on Pentium-compatible hardware
  • Processor: Pentium-compatible
  • 126MB of disk space for a complete installation of the Professional or Enterprise Edition with documentation
  • 110MB of disk space for a complete installation of the Personal Edition with documentation

Please see the note below about Windows emulators.


LispWorks 5.0 (64-bit) for Windows

  • Windows Vista 64-bit Editions, Windows XP Professional x64 Edition or Windows Server 2003 x64 Editions
  • Processor: AMD64-compatible, including Intel 64
  • 140MB of disk space for a complete installation of the Enterprise Edition with documentation

LispWorks® for Unix 5.0

Hardware Requirements

  • Memory - 32MB required, 64MB or more recommended
  • Swap space - 20MB minimum recommended, plus more for your application code
  • Disk space - up to 150MB required, including documentation. More is needed for saving custom images

Platforms

Platform

OS

Foreign Library Support

HP PA

HP-UX

Shared

SUN SPARC

Solaris

Shared

The LispWorks IDE on Unix requires Motif 2



LispWorks® for Macintosh® 4.4

Hardware Requirements

  • Processor: PowerPC G3, G4 or G5
  • An "Easy Install" of the Professional or Enterprise Edition which includes all the documentation requires 108MB
  • The native IDE alone needs 43MB
  • The X11/Motif IDE alone needs 54MB
  • The documentation alone needs 71MB
  • The Personal Edition together with its HTML documentation requires 68MB.

Platforms

LispWorks for Macintosh supports Mac OS X version 10.3 or later.

LispWorks® for Linux® 4.4

Hardware Requirements

  • Processor: 486DX minimum, Pentium recommended.
  • Memory - 32MB required, 64MB or more recommended for good performance
  • Disk Space - 43MB minimum required
  • More disk space is required to install the documentation. A full installation of the Enterprise Edition including the documentation and all modules requires about 186MB.
  • The Personal Edition together with its HTML documentation requires 84MB.

Platforms

LispWorks for Linux supports Redhat Linux (versions 6 through 9) on Pentium-compatible CPU. Also Mandrake and SuSE Linux with kernel 2.2 or later on Pentium-compatible CPU.

The LispWorks IDE on Linux requires one of:

  • Open Motif 2.2 or higher
  • Lesstif 0.93.18 or higher

LispWorks® for Windows® 4.4

Hardware Requirements

  • Processor: 486DX minimum, Pentium recommended.
  • Memory - 32MB required, 64MB or more recommended
  • Disk space - 57MB minimum required
  • More disk space is required if you install the documentation. The PDF documentation takes about 27MB, and the HTML documentation takes about 34MB.
  • The Personal Edition together with its HTML documentation requires 66MB.

Platforms

LispWorks for Windows supports Windows 98/Millennium, Windows NT4.0, Windows 2000 and Windows XP running on Pentium-compatible hardware.

LispWorks® for Unix 4.4

Hardware Requirements

  • Memory - 32MB required, 64MB or more recommended
  • Swap space - 20MB minimum recommended, plus more for your application code
  • Disk space - up to 140MB required, including documentation. More is needed for saving custom images

Platforms

Platform

OS

Foreign Library Support

HP PA

HP-UX

Shared

DEC Alpha

OSF 1

Shared

SUN SPARC

Solaris

Shared

The LispWorks IDE on Unix requires Motif 1.2.4



Virtual Machines and Windows Emulators

We cannot guarantee support for all VMs and emulators.

We have had a report (February 2013) of the LispWorks 6.1 Professional for Macintosh installer crashing in a VMware7,1 Mac OS X 10.8 virtual machine. We have made a rebuild of the LispWorks installer which may fix this.

LispWorks 6.0 has been reported to run without problems on:

  • Windows 7 under VMware Fusion running on Mac OS X
  • Windows XP in a Parallels Desktop VM on an Intel MacBook
  • Windows XP/Vista/7 (32-bit and 64-bit) under VMware Server hosted on Windows
  • Linux (32-bit and 64-bit) under VMware Server hosted on Windows
  • FreeBSD under VMware Server hosted on Windows
  • Open Solaris x86/x64 (32-bit and 64-bit) under VMware Server hosted on Windows
  • Linux in a Parallels Desktop VM on a MacBook
  • Windows XP under VirtualBox hosted on FreeBSD

LispWorks 5.x has been reported to run without problems on:

  • Windows under VMware Server hosted on Windows
  • Linux under VMware Server hosted on Windows
  • Windows XP in a Parallels Desktop VM on an Intel MacBook

LispWorks 4.x has been reported to run without problems on:

  • Windows (NT, 2000, XP) under VMware under linux
  • Windows 98 running in QEMU hosted on FreeBSD 4.10
  • Windows 95 running in Virtual PC 6.0.1 on Mac OS X 10.3.5, PowerBook G4 (installed CygWin to make ASDF-Install work)
  • Windows emulator in VMware on Linux guest system
  • wine

If you have run LispWorks on a VM or emulator, please tell us at , mentioning the LispWorks version, VM or emulator name, and the host OS. We are interested to know about any specific problems found. We would also like to know if it simply works.

Please note that the standard LispWorks End User License Agreement specifies that a virtual machine is just like a physical computer when counting the number of installations for licensing purposes. The license can be read from within LispWorks by choosing Help > About LispWorks... and clicking License Terms.

Top | Back