The integrated cross-platform development tool for ANSI Common Lisp LispWorks logo

Lisp Knowledgebase



Title: Running LispWorks under FreeBSD

ID: 17006


Product: LispWorks for Linux
Version: 4.0.1, 4.1, 4.2, 4.3, 4.4
OS: FreeBSD

Description:
LispWorks 4.x for Linux can be run under the FreeBSD operating system by using FreeBSD's Linux compatibility module. The following notes apply to this configuration:

1. You must have FreeBSD version 4.1 or newer (because of a bug in mmap()).

2. You must have the Linux versions of the Motif or Lesstif shared libraries, not the FreeBSD ones.

3. You may need to add some symbolic links in /compat/linux/usr/X11R6/lib from the motif library needed by LWL to the actual library you installed. See KB article 16015 (link), prepending /compat/linux to the pathnames mentioned.


NB LispWorks 5+ for Linux does not run on FreeBSD. Use LispWorks for FreeBSD instead.

See Also: 16015 (link)
Workaround:
Patch:

Hardware:N/A
Summary:Information about running LispWorks for Linux under FreeBSD's Linux compatibility module
Bug#:
Patch Enhancement#:
Reported:

Top | Back