The integrated cross-platform development tool for ANSI Common Lisp LispWorks logo

Lisp Knowledgebase



Title: LispWorks executable corrupted on Leopard

ID: 17060


Product: LispWorks for Macintosh
Version: All
OS: Mac OS X 10.5

Description: The security system in Mac OS 10.5 (Leopard) corrupts LispWorks executables when the OS stores firewall settings per application in the application file itself. This destroys the LispWorks image.

To avoid this problem, in the firewall settings of your system, select either

Allow all incoming connections

or

Allow only essential services

Do not select Set access for specific services and applications.

The problem may have gone away in Mac OS X 10.5.4. We would be interested to hear if you have encountered it in this or a later version of Mac OS X.

Note: LispWorks 6.0 (and later) development images and runtimes that are saved/delivered with the keyword :split non-nil do not have this problem. See the documentation for save-image (it is applicable to deliver too).

See Also:
Workaround:
Patch:

Hardware:N/A
Summary:
Bug#:
Patch Enhancement#:
Reported:

Top | Back