All Manuals > LispWorks IDE User Guide > 2 A Short Tutorial


2.1 Starting the environment

To start LispWorks on Microsoft Windows:

  1. Click Start on the task bar.
  2. From the Start menu, choose All Programs > LispWorks 6.1 > LispWorks .

You should see a splash screen, followed by the podium window. The podium is shown in The podium. A Listener window will also appear if your image is configured to start one.

Figure 2.1 The podium

The podium window is automatically displayed whenever you start the LispWorks IDE. Its menu bar gives you access to various commands, as well as all the other tools in the environment. Its toolbar gives you quick access to some of the more convenient menu commands. This screenshot shows the podium as it appears in 'Separate windows sharing a menu bar' mode.

Like many other applications, the menu bar contains File , Edit , Tools , Windows and Help menus and a LispWorks specific menu named Works . The Works menu contains commands that apply to the active window in the LispWorks environment. The title of the active window is shown in the LispWorks podium, underneath the toolbar.

The File menu allows you to open a file in an Editor, or print a file, regardless of which window is active. When the Editor or Listener tool is active, the File menu contains other commands for miscellaneous operations on the file displayed. The Tools menu gives you access to all of the tools in the LispWorks IDE. The Windows menu lists all the active LispWorks windows you have running.

Note: If you wish to exit the Lisp image during this tutorial or at any other time, choose File > Exit .

LispWorks IDE User Guide (Windows version) - 25 Nov 2011