LispWorks IDE User Guide > 2 A Short Tutorial


2.1 Starting the environment

On Linux and FreeBSD, assuming that you have the LispWorks executable location in your path, just type its name in any xterm or command shell window. This name is lispworks-6-0-0-x86-linux , lispworks-6-0-0-amd64-linux or lispworks-6-0-0-x86-freebsd depending on which product you are running. Under KDE or Gnome, you might want to set up a system menu item to start LispWorks.

On Solaris and HP-UX, the supplied image is in the lib/6-0-0-0/config directory of the LispWorks installation. You may have a configured image elsewhere.

On Linux and FreeBSD, the LispWorks environment starts automatically in the supplied image. On Solaris and HP-UX, the LispWorks environment starts when the command line argument -env is specified. If -env is not specified, LispWorks will start in terminal ("tty") mode with a prompt similar to the following:


Type the following Lisp form at the prompt to start the LispWorks environment:


After a short pause, you should see a splash screen, followed by the Podium window. The Podium is shown in The Podium. A Listener window will also appear if your image is configured to start one.

Figure 2.1 The Podium

The Podium window is automatically displayed whenever you start the LispWorks IDE. Its menu bar gives you access to various commands, as well as all the other tools in the environment. Its toolbar gives you quick access to some of the more convenient menu commands.

Like many other applications, the menu bar contains File , Tools , Windows and Help menus and a LispWorks specific menu named Works . The Works menu contains commands that apply to the current window and also contains menus that allow navigation between tools in the LispWorks environment .

The File menu allows you to open a file in an Editor, or print a file, regardless of which window is active. When the Editor or Listener tool is active, the File menu contains other commands for miscellaneous operations on the file displayed. The Tools menu gives you access to all of the LispWorks IDE tools. The Windows menu lists all the active LispWorks windows you have running.

Note: If you wish to exit the Lisp image during this tutorial or at any other time, choose Works > Exit > LispWorks .

2.1.1 The Lisp Monitor

LispWorks IDE User Guide (Unix version) - 22 Dec 2009