LispWorks IDE User Guide > 3 Common Features


3.11 Linking tools together

You can link together pairs of tools, so that changing the information displayed in one tool automatically updates the other. This can be done for virtually any tool in the LispWorks IDE, and provides a simple way for you to browse information and see how the state of the Lisp environment changes as you run your code. For instance, you can make between an Inspector and a Listener so that every time you evaluate a form in the Listener, its value is automatically inspected.

You can also link two copies of the same tool. This can be a very useful way of seeing two views of a tool at once. For instance, you could create a copy of the Class Browser by choosing Window > Clone , and then link them together. By keeping one browser in the subclasses view, and the other in the slots view, you can automatically see both the subclasses and the available slots for a given class.

Linked tools have a master-slave relationship. One tool (the slave) gets updated automatically, and the other tool (the master) controls the linking process. To link together any two tools:

  1. Select the tool that the link is to be established to. For example, to form a link from an Inspector to a Class Browser to ensure that a class selected in the Class Browser is automatically inspected, you would use the Edit menu of the Class Browser.
  2. Choose Edit > Link > fromtool where fromtool is the title of the tool you wish to link from.

To break a link, select -- No Link -- instead of a specific tool.

To view all the current links that have been established, choose Edit > Link from > Browse Links... Select any of the links listed and click on Remove Link(s) to remove them.

LispWorks IDE User Guide (Macintosh version) - 22 Dec 2009