24.3 The System Browser

The System Browser provides an intuitive graphical way to examine and operate on systems and their members.

For example, the operation outlined in A brief introduction to systems would be performed by the System Browser menu commands Systems > Compilation options > Force followed by Systems > Compile .

To create a System Browser, choose Window > Tools > System Browser or press in the LispWorks toolbar. Alternatively, choose File > Browse Parent System from any appropriate tool in the environment or execute Esc X Describe System in an editor, to display the parent system for the selected or current file in the System Browser. See Operating on files for details.

In order to browse a system, first ensure it is defined. To define a system, load the Lisp source code containing the defsystem form into the Lisp image. For instance, open the file in an Editor and choose File > Load . Alternatively, choose File > Load... from the System Browser and choose a file to load in the dialog that appears.

Common LispWorks User Guide (Macintosh version) - 5 Jul 2006