3 Common Features

The Common LispWorks environment has been designed so that its features are consistent throughout, and tools have a uniform look and feel. All tools have certain characteristics which look the same, and behave in a consistent manner. By making as many common features as possible, learning how to use each tool is much simpler.

A Short Tutorial, introduced you to some of the major tools in the environment, demonstrating the commonality and high integration between them, and showing how this can be used to good effect in the development process. This chapter describes these common features in more detail.

Most of the common features in the environment can be found under the File , Edit , Works , History, Windows and Help menus. If you are using the MDI LispWorks interface for Windows, these menus are located in the single main MDI window. (Remember, you can toggle between multiple LispWorks windows and the MDI interface using the Tools > Global Preferences... menu command.) Using the commands available under these menus you can:

Each menu command operates on the window associated with the menu. In LispWorks for Windows in "All windows contained within a single main window" (MDI) mode or "Separate windows sharing a menu bar" mode, there is a single menu bar on the podium and one window is always the "Active Window". The menu commands act on the Active Window. Its name is displayed at the bottom of the podium. The Active Window can be any window within the Common LispWorks environment: even the podium itself.

In addition, some other conventions have been adopted throughout the Common LispWorks environment:

These features are described in full in this chapter. Please note that subsequent descriptions of individual tools in the environment do not include a description of these menus, unless a feature specific to the individual tool is described.

Online help is also available from the Help menu in any window. These facilities are described in Getting Help.

Many tools allow you to display information in the form of a graph. These graph views behave consistently throughout the environment, and a description of the graph features offered is given in Manipulating Graphs.

3.1 Displaying tool windows

3.2 Setting global preferences

3.3 Quitting the environment

3.4 Performing editing functions

3.5 The history list

3.6 Operating on files

3.7 Displaying packages

3.8 Performing operations on selected objects

3.9 Using different views

3.10 Tracing symbols from tools

3.11 Linking tools together

3.12 Filtering information

3.13 Examining a window

Common LispWorks User Guide (Windows version) - 11 Apr 2005