2.1 Starting the environment

To start LispWorks on Windows 95, Windows 98, Windows NT 4.0, Windows 2000, or Windows XP:

  1. Click Start on the task bar.
  2. From the Start menu, choose Programs > LispWorks .

After a short pause, you should see a splash screen, followed by the podium window. The podium is shown in The podium. A Listener window will also appear if your image is configured to start one.

Figure 2.1 The podium

The podium window is automatically displayed whenever you start the Common LispWorks environment. Its menu bar gives you access to various commands, as well as all the other tools in the environment. Its toolbar gives you quick access to some of the more convenient menu commands. This screenshot shows the podium as it appears in 'Separate windows sharing a menu bar' mode.

Like many other applications, the menu bar contains File , Edit , Tools , Windows and Help menus and a LispWorks specific menu named Works . The Works menu contains commands that apply to the active window in the LispWorks environment . The title of the active window is shown in the LispWorks podium, underneath the toolbar.

The File menu allows you to open a file in an Editor, or print a file, regardless of which window is active. When the Editor or Listener tool is active, the File menu contains other commands for miscellaneous operations on the file displayed. The Tools menu gives you access to all of the Common LispWorks tools. The Windows menu lists all the active LispWorks windows you have running.

Note: If you wish to exit the Lisp image during this tutorial or at any other time, choose File > Exit .

Common LispWorks User Guide (Windows version) - 11 Apr 2005