8.12 Using Lisp-specific commands

8.12.2 Compiling code

You can also compile Lisp code in an editor buffer in much the same way that you can evaluate it.

Choose Buffers > Compile to compile all the code in the current buffer.

Choose Expression > Compile Region to compile the Lisp code in the current region.

Choose Definitions > Compile to compile the definition in which the cursor currently lies.

During compilation, the editor window temporarily displays compiler output in an output window. Once compilation has finished, press the space bar to display the current buffer once again. You can view this output window at any time by choosing View > Output.

To compile the code for any file, even if it is not loaded into the editor, choose File > Compile. You are prompted for a filename in the echo area. If you wish to load the compiled code into the environment as well, choose File > Compile and Load.

Common LispWorks User Guide, Liquid Common Lisp Version 5.0 - 18 OCT 1996

Generated with Harlequin WebMaker