8 The Editor

8.9 Cutting, copying and pasting using the clipboard

The editor provides the standard methods of cutting, copying and pasting text using the clipboard. To select a region of text, click and hold down the select button, and drag the pointer across the region you want to select: the text is highlighted as you select it.

Choose Edit > Select All to select all the text in the buffer, and Edit > Deselect All if you want to deselect it.

Once you have selected a region use either of the following commands:

Choose Edit > Copy to copy the region to the clipboard. This leaves the selected region unchanged in the editor buffer.

Choose Edit > Cut to delete the region from the current buffer, and place it in the Common LispWorks clipboard. This removes the selected region from the buffer.

Choose Edit > Paste to copy text from the clipboard into the current buffer. The text is placed at the current cursor position.

These commands are also available from a popup menu which can be displayed in the same way that the Graph menu can be displayed in the Graph area of a tool. This is usually achieved by clicking the right mouse button, but if you are unsure you should consult the documentation for your operating system or window manager.

The editor also provides a much more sophisticated system for cutting, copying and pasting text, as described below.

Common LispWorks User Guide, Liquid Common Lisp Version 5.0 - 18 OCT 1996

Generated with Harlequin WebMaker